Page tree
Skip to end of metadata
Go to start of metadata

Pluma представляет собой текстовый редактор, который поддерживает большинство стандартных функций редактора. Он также расширяет эту базовую функциональность с помощью других функций, которые обычно не встречаются в простых текстовых редакторах. Pluma это графическое приложение, которое поддерживает редактирование нескольких текстовых файлов в одном окне (иногда называемые вкладками или MDI). Pluma полностью поддерживает международный текст благодаря использованию кодировки Юникод UTF-8 в отредактированных файлах. Основной набор функций включает синтаксис, подсветку исходного кода, автоматический отступ и поддержку печати (с предварительным просмотром печати).

Чтобы открыть Pluma, нужно выполнить следующие действия:

1. Открыть панель меню в левом нижнем углу.

2. Далее выбрать пункт стандартные и выбрать вкладку Pluma.

При запуске pluma отображается следующее окно:

Окно pluma содержит следующие элементы:

1. Строка меню
Меню на панели меню содержат все команды, необходимые для работы с файлами в pluma.

2. Панель инструментов
Панель инструментов содержит подмножество команд, к которым вы можете получить доступ из панели меню.

3. Область отображения
Область отображения содержит текст редактируемого файла.

4. Статусная строка

В строке состояния отображается информация о текущей активности pluma и контекстная информация о пунктах меню. В строке состояния также отображается следующая информация:

  • Положение курсора: номер строки и номер столбца, в которых находится курсор.
  • Режим редактирования: Если редактор находится в режиме вставки, строка состояния содержит текстовые вставки. Если редактор находится в режиме перезаписи, строка состояния содержит текст OVR. Нажмите клавишу вставки, чтобы изменить режим редактирования.

Боковое стекло

На боковой панели отображается список открытых документов и другая информация в зависимости от того, какие плагины включены.

По умолчанию боковая панель не отображается. Чтобы отобразить его, выберите Вид ▸ Боковая панель.

Нижняя панель

Нижняя панель используется инструментами программирования, такими как плагин консоли Python, для отображения выходных данных.

По умолчанию нижняя панель не отображается. Чтобы отобразить его, выберите Вид ▸ Нижняя панель.

Когда вы щелкаете правой кнопкой мыши в окне pluma, приложение отображает всплывающее меню. Всплывающее меню содержит наиболее распространенные команды редактирования текста.

Как и в других приложениях MATE, действия в pluma можно выполнять несколькими способами: с помощью меню, панели инструментов или сочетаний клавиш.

Создание нового документа

Чтобы создать новый документ, выберите Файл ▸ Создать. Приложение отображает новый пустой документ в окне pluma.

Открытие файла

Чтобы открыть файл, выберите Файл в нём выберите пункт открыть.

Сохранение файла

Вы можете сохранять файлы следующими способами:

  • Чтобы сохранить изменения в существующем файле, выберите Файл ▸ Сохранить.
  • Чтобы сохранить новый файл или существующий файл под новым именем, выберите Файл ▸ Сохранить как. Введите имя файла в диалоговом окне Сохранить как, затем нажмите Сохранить.

Открытие файла из URI

Чтобы открыть файл с помощью единого идентификатора ресурса (URI), выполните следующие действия:

1. Выберите Файл ▸ Открыть местоположение, чтобы открыть диалоговое окно Открыть местоположение.

2. Введите URI файла, который вы хотите открыть.

3. Используйте раскрывающийся список Кодировка символов, чтобы выбрать соответствующую кодировку символов.

5. Нажмите кнопку Открыть.

Допустимые типы URI включают http:, ftp:, файл: и все методы, поддерживаемые mate-vfs.

Файлы из некоторых типов URI открываются только для чтения, и любые внесенные вами изменения должны быть сохранены в другом месте. HTTP позволяет читать только файлы. Файлы, открытые с FTP, доступны только для чтения, поскольку не все FTP-серверы могут корректно работать с сохранением удаленных файлов.

Сохранение на FTP-серверах можно включить с помощью редактора конфигурации, установив ключ /приложения/pluma/настройки/редактор/сохранить/записываемые_ф_схемы, но это может привести к ошибкам.

Работа С Вкладками

Когда открыто более одного файла, pluma показывает вкладку для каждого документа над областью отображения. Чтобы перейти к другому документу, нажмите на его вкладку.

Чтобы переместить документ в другое окно pluma, перетащите вкладку, соответствующую файлу, в окно, в которое вы хотите его переместить.

Чтобы переместить документ в новое окно pluma, либо перетащите его вкладку на рабочий стол, либо выберите Документы ▸ Переместить в Новое окно.

Файлы из некоторых типов URI открываются только для чтения, и любые внесенные вами изменения должны быть сохранены в другом месте. HTTP позволяет читать только файлы. Файлы, открытые с FTP, доступны только для чтения, поскольку не все FTP-серверы могут корректно работать с сохранением удаленных файлов.

Сохранение на FTP-серверах можно включить с помощью редактора конфигурации, установив ключ /приложения/pluma/настройки/редактор/сохранить/записываемые_ф_схемы, но это может привести к ошибкам.

Редактирование текста

Вы можете редактировать текст файла следующими способами:

Введите новый текст с клавиатуры. Мигающий курсор вставки отмечает точку, в которой появляется новый текст. Чтобы изменить это, используйте клавиши со стрелками на клавиатуре или щелкните мышью.

Чтобы скопировать выделенный текст в буфер обмена, выберите Правка  ▸ Копировать.

Чтобы удалить выделенный текст из файла и переместить выделенный текст в буфер обмена, выберите Правка ▸ Вырезать.

Чтобы окончательно удалить выделенный текст из файла, выберите Правка ▸ Удалить.

Чтобы вставить содержимое буфера обмена в положение курсора, выберите Правка ▸ Вставить. Вы должны вырезать или скопировать текст, прежде чем сможете вставить текст в файл, либо из pluma, либо из другого приложения.

Чтобы выделить весь текст в файле, выберите Правка ▸ Выбрать все.

Поиск текста

Чтобы выполнить поиск строки текста в файле, выполните следующие действия:

1. Выберите Поиск ▸Поиск, чтобы открыть диалоговое окно поиска.

2. Введите строку, которую вы хотите найти, в поле Искать.

3. Нажмите кнопку Найти, чтобы выполнить поиск в файле по первому вхождению строки после вашего текущего положения курсора. Если pluma находит строку, приложение выбирает первое вхождение строки. Другие вхождения строки выделяются

Пошаговый поиск

Инкрементный поиск выделяет соответствующий текст в документе по мере его ввода буква за буквой. (Это похоже на функцию поиска в нескольких веб-браузерах.)

Чтобы начать инкрементный поиск, выберите Поиск ▸ Пошаговый поиск. Поле поиска появится в верхней части области отображения.

Начните вводить текст, и соответствующий текст будет выделен в документе. Также выбирается первый экземпляр после позиции курсора.

Чтобы перейти к следующему совпадению, не открывая окно инкрементного поиска, нажмите Ctrl+G. Нажмите Ctrl+Shift+G, чтобы вернуться к предыдущему совпадению.

Вы также можете использовать клавиши со стрелками вверх и вниз или колесико мыши для перемещения выбора между совпадениями.

Замена текста

Чтобы выполнить поиск строки в файле и заменить строку альтернативной строкой, выполните следующие действия:

1. Выберите Поиск ▸ Заменить, чтобы открыть диалоговое окно Заменить.

2. Введите строку, которую вы хотите найти, в поле Поиск. Вы можете включить специальные символы, такие как новая строка или вкладка.

3. Введите строку, которую вы хотите использовать для замены найденной строки, в поле Заменить на.

Чтобы проверить каждое вхождение строки перед ее заменой, нажмите кнопку Найти. Если pluma находит строку, приложение выбирает строку. Нажмите кнопку Заменить, чтобы заменить выбранное вхождение строки. Чтобы найти следующее вхождение строки, нажмите кнопку Найти еще раз.

Чтобы заменить все вхождения строки во всем документе, нажмите кнопку Заменить все.

Специальные символы

Вы можете включить следующие escape - последовательности в текст, чтобы найти или заменить их для представления специальных символов:

\n

Задает новую строку.

\t

Задает символ табуляции.

\r

Указывает возврат каретки.

\\

Сам символ обратной косой черты должен быть экранирован, если его ищут. Например, если вы ищете литерал "\n", вам нужно будет ввести "\\n" в поле поиска. Или, если вы ищете последовательность обратных косых черт, вам придется удвоить количество искомых обратных косых черт.

Наведение курсора на определенную строку

Чтобы установить курсор на определенную строку в текущем файле, выберите Поиск ▸ Перейти к строке. В верхней части области отображения появится поле с номером строки.

Начните вводить номер строки, на которую вы хотите переместить курсор, и документ будет прокручиваться до указанной строки.

Чтобы закрыть окно и переместить курсор в указанную строку, нажмите клавишу Return.

Печать документа

Вы можете использовать pluma для выполнения следующих операций печати:

Распечатайте документ на принтере.

Распечатайте выходные данные команды печати в файл.

Если вы печатаете в файл, pluma отправляет выходные данные файла в файл формата для предварительной печати. Наиболее распространенными форматами предварительной печати являются PostScript и Формат переносимых документов (PDF).

Чтобы просмотреть страницы, которые вы хотите распечатать, выберите Файл ▸  просмотр печати .

Чтобы распечатать текущий файл на принтере или в файле, выберите Файл ▸ Печать, чтобы открыть диалоговое окно Печать.

Подсветка синтаксиса

Подсветка синтаксиса облегчает чтение исходного кода, показывая разные части текста разными цветами.

pluma выбирает подходящий режим подсветки синтаксиса в зависимости от типа документа. Чтобы переопределить режим подсветки синтаксиса, выберите Вид ▸ Режим подсветки, затем выберите один из пунктов меню.

Передача выходных данных команды в файл

Вы можете использовать pluma для передачи выходных данных команды в текстовый файл. Например, чтобы передать вывод команды ls в текстовый файл, введите ls | pluma, затем нажмите клавишу Return.

Вывод команды ls отображается в новом текстовом файле в окне pluma.

Кроме того, вы можете использовать плагин внешних инструментов для передачи вывода команд в текущий файл.

Просмотр настроек

Перенос текста

Выберите опцию Включить перенос текста, чтобы длинные строки текста перетекали в абзацы, а не выходили за пределы текстового окна. Это позволяет избежать необходимости горизонтальной прокрутки

Выберите опцию Не разделять слова на две строки, чтобы опция переноса текста сохраняла целые слова при переносе текста на следующую строку. Это облегчает чтение текста.

Номера строк

Выберите опцию Отображать номера строк, чтобы отобразить номера строк в левой части окна pluma.

Текущая Строка

Выберите опцию Выделить текущую строку, чтобы выделить строку, на которой находится курсор.

Правое поле

Выберите опцию Отображать правое поле, чтобы отобразить вертикальную линию, обозначающую правое поле.

Используйте правое поле в поле "Поворот столбца", чтобы указать расположение вертикальной линии.

Соответствие кронштейнов

Выберите опцию Выделить соответствующую скобку, чтобы выделить соответствующую скобку, когда курсор находится на символе скобки.

Настройки редактора

Вкладки

Используйте поле "Ширина вкладки", чтобы указать ширину пространства, которое pluma вставляет при нажатии клавиши Tab.

Выберите опцию Вставить пробелы вместо вкладок, чтобы указать, что pluma вставляет пробелы вместо символа табуляции при нажатии клавиши табуляции.

Автоматическое Отступление

Выберите опцию Включить автоматическое отступление, чтобы указать, что следующая строка начинается с уровня отступа текущей строки.

Сохранение файла

Выберите опцию Создать резервную копию файлов перед сохранением, чтобы создавать резервную копию файла при каждом сохранении файла. Резервная копия файла содержит символ ~ в конце имени файла.

Выберите файлы автосохранения каждый раз ... опция минут для автоматического сохранения текущего файла через регулярные промежутки времени. Используйте поле "Вращение", чтобы указать, как часто вы хотите сохранять файл.

Настройки шрифта и цветов

Шрифт

Выберите опцию Использовать шрифт темы по умолчанию, чтобы использовать системный шрифт по умолчанию для текста в текстовом окне pluma.

В поле Шрифт редактора отображается шрифт, который pluma использует для отображения текста. Нажмите на кнопку, чтобы указать тип шрифта, стиль и размер, которые будут использоваться для текста.

Цветовая гамма

Вы можете выбрать цветовую схему из списка цветовых схем. По умолчанию установлены следующие цветовые схемы:

Классический

Классическая цветовая схема, основанная на цветовой схеме gvim.

Кобальт

Цветовая гамма на основе синего.

Кейт

Цветовая схема, используемая в текстовом редакторе Kate.

Забвение

Темная цветовая гамма с использованием цветовой палитры Tango.

Танго

Цветовая схема с использованием цветовой схемы Tango.

Вы можете добавить новую цветовую схему, нажав кнопку Добавить... и выбрав файл цветовой схемы

Вы можете удалить выбранную цветовую схему, нажав на кнопку Удалить.

  • No labels